using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=(?|("")([^""<>\s]*)()(?=[\s>]|\/>)|(?!"")()([^""<>\s]*)(""))";
string substitution = @"=""$2""";
string input = @"<table pgwide=""0"" id=""dvr_config_firmware>
<title>DFR Firmware</title>
<tgroup cols=""2"">
<colspec colname=""col1>
<colspec colname=""col2"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}