const regex = /=(?|(")([^"<>\s]*)()(?=[\s>]|\/>)|(?!")()([^"<>\s]*)("))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=(?|(")([^"<>\\s]*)()(?=[\\s>]|\\\/>)|(?!")()([^"<>\\s]*)("))', 'gm')
const str = `<table pgwide="0" id="dvr_config_firmware>
<title>DFR Firmware</title>
<tgroup cols="2">
<colspec colname="col1>
<colspec colname="col2">`;
const subst = `="$2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);