# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"お買\n\d\s*\d*[,|\d|\s*][\s|\d]*"
test_str = ("人\n\n"
"洋服ゅ青山\n\n"
"其深阪店\n"
"TEL 072-294-8130\n\n"
"FN 情報満載 ! 2\n"
"洋服の青山」のホームページ\n"
"http ://uuu. y-aoyama, jp\n\n"
"人 4月 27日 (火) 11:04\n\n"
"お買\n"
"1 5, 060\n"
"Ri\n"
"4, 600\n\n"
"*印は値引・割引対象外となります\n"
"(ポイト 発行対象金額 0)\n\n"
"て顧窒ポイントン>\n"
"会計前ポイント 140PT\n"
"通常ポイント内訳\n"
"(2022年03月末まで UPT)\n"
"(2023年03月末まで OPT)\n"
"(2024年03月末まで 140PT)\n"
"(2025年03月末まで OPT)\n"
"今回付与記選ト OPT\n"
"今回利用記選ト OPT\n"
"利用可能 ト 140PT\n\n"
"NHIボポイレトラテ\n\n"
"「 会員番号 *k*xxxxxxxxk]ロ73\n"
"今回付与T記人ト 23PT\n"
"今回利用TP履ト 32PT\n"
"利用可能TP 人ト OPT\n\n"
"本日時まったポイントは、\n"
"翌日以降に反映されます。\n\n"
"Tカードが無効の場合、\n\n"
"Tポイントは貯まりません。\n"
"詳細はuuu.tsite. jpにて\n\n"
"ご確認下さい。\n\n"
"店]-ド\"000517 尺\"No.05 0367529\n"
"担当:大川\n\n"
"M串川\n"
"の| アプ\n"
"堺インタ\n"
" 072-294-7233\n\n"
"領 収 証\n\n"
"2021年04月17日(土)12:35 ゆび0634\n\n"
"No04300106野地\n"
"裁録機 0133 登録No8864\n"
"※サントリー天然水ケース 398\n"
"ハミング消臭ジャス詰替 \\168\n"
"*みず菜 \\100\n"
"*日清焼そばソース付3人 \\89\n"
"ばれいしょ \\298\n\n"
"A* 宮城県産ひとめぼれ5 k \\1.499 軒\n"
"昌 小計 \\2.552 較\n\n"
"則 (外8% 対象 \\2, 384)\n\n"
"| 分8 \\190\n"
" -和 (外10% 対象 \\168)\n"
"( | 外10 \\16\n\n"
"支払合計 デジ 。 アロ\n"
"人凍\n\n"
"に XXXXXXXXXXXX4754\n"
">ン LaCuCa残高 \\3. 313\n"
"下| *印は軽減税率(8%)適用の商品です\n"
" ーーー----- L6ノ LaCUOa --ー--ニニニニニ=\n"
"|ポト対象金額\n"
"今回取引人選ト\n"
"LaCuCa決済P対象金額\n"
"LaCuCa決済P\n\n"
" \n\n"
"まう\n\n"
"会員番号 278XXXXXX4751\n\n"
"ll川作\n\n"
"ゆ-トNo6452 。 店Ne00430\n"
"とくガ\n"
" で andQi\n\n"
"(株)万代 堺大庭寺店\n"
"Tel:072-294-5020\n\n"
"hUD 7/7www mar net CO ID\n\n"
"領 収 書\n\n"
"求求氷求素来来求素沙素素求玉求玉\n"
"毎週土曜日 にmandai payで支払 デー\n"
"ポイントが3借になります! !\n\n"
"ぜひこ利用くださいませ\n"
"求求玉来氷求氷氷素素来素来来来玉\n\n"
"2021年 4月 9日 (金) 11:48\n\n"
"州12 本仕込食パン6 枚切\n\n"
"\\100 2個 \\200\n"
"州12 Jラーマバターフウ 00\n"
"州05 キャ ベツ \\98\n"
"州09 グランドアルト2B \\298\n"
"VH05 生竹の子 \\580\n"
"誕05 人参_ \\158\n"
"00 (いち\n\n"
"\\298 2個 \\596\n"
"州18 Aたたきのっけ盛造 \\399\n"
"導18 A真鯛お造り (玖殖) \\399\n"
"首18 A4しめさばお造り \\399\n"
"*A 3個 \\1, 000 -\\197\n\n"
"\\1, 197を\\1, 000にしました\n\n"
"小 12点 \\3, 030\n\n"
"(外税 8.0%対象額 \\3, 030)\n"
"8.0 消費税等 \\242\n"
"日 \\242\n\n"
"2 は軽減税率対象商品です。\n\n"
"合『 学づごアジ\n"
"ポイント利用 [回 Y72\n"
"現計 学づどりO\n"
"お預り 学ら. OO\n"
"お釣り 学忌。 DOO\n\n"
"会員番号 *****x*****5440\n\n"
"<ポイント情報テン\n"
"ント計集る額 3Gao円\n"
"イイ\n\n"
"-7233\n\n"
"2021年04月15日(木)11:52 \"0636\n\n"
"No04300110原田\n"
"富録機 0134 登録No4586\n"
"*※日の出 料理酒1000\n"
"*※生しいたけ (菌床)\n"
"*※セロリ\n"
"*※*]本 白ねぎ\n"
"2コX単59\n"
"リリキーグラソドイコク舞い見\n"
"2コX単298 \\596\n"
"衣特典ポイント 40P\n"
"※メロディアンソンミニ45コ入 痢38\n"
"*ネスマイルライフもめん ゃ58\n"
"*ほうれん草 \\98\n"
"胃 Aネホホクトエリンギ100G \\79\n"
"A※超国まいたけ (極) \\79\n"
"| A*ネえのき萌 \\/9\n\n"
"\\138\n"
"\\138\n"
"\\100\n\n"
"\\118\n\n"
"Aキノコヨリト“リ\n\n"
"\\237から\n\n"
"小計\n\n"
"(外8% 対象\n\n"
"外8%\n"
"支払合計\n"
"LaCuCa支払\n"
" お買上点数\n\n"
" 信子マ番号\n\n"
"( 3個) -97\n"
"\\200に致します\n"
"\\1.584\n\n"
"584 )\n"
"\\126\n"
"/ルし\n"
"\\1.710\n\n"
"つ\n\n"
"ギ]\n\n"
"13店\n"
"LaCu支反\n\n"
"XOXO4754\n\n"
"細四 |aCuCa残高 5, 071\n\n"
"* Eは軽減税率(8%)適用の商品です\n"
"LCプLaCuCa\n\n"
"訪履ト対象金額\n"
"今回取引人履ト\n"
"特典ポイント\n"
"LaCuCa決済P対象金額\n"
"LaCuCa決済P\n\n"
"\\].584\n"
"D2 ケーヨーテイツー\n\n"
"* 泉北原山台店 *TEL 072-296-4466\n\n"
"頭 収 書\n\n"
"培いT\n"
" 換は、 1 週間以内に\n"
"も します。レシートを\n\n"
"一緒にお持ち下さい。\n\n"
"2021年 4月28日 (水) 11:54\n"
"側h&Sリルリッ] 2人7リ \\っ4 /\n"
"本7 が-ドWP\\っ4 /\n\n"
"測 税10 08 094\n"
"0 2 人 99\n\n"
"舎g 共和1。 ロロ94\n"
"ポイント利 用対象\n"
"ポイント\n\n"
"209\n\n"
"<ぐポイント情報シ>\n"
"ボボネネ3221\n"
"\\995\n"
"4\n"
"-4\n"
"0 9\n\n"
"基本\n"
"隊 i 限 。 要凡//*\n"
"ます\n"
"E を内側に折って保管下さい\n\n"
"ポイントが最大 5 是元| !\n"
"ORき\n\n"
"ごF\n\n"
"SKU\n\n"
"会員番\n"
"ポイン\n"
"今回ポ\n"
"ポ\n"
"ス\n\n"
"山へへヘテ貼和信\n"
"|NSN3S\n\n"
"プ\n\n"
"NS\n\n"
"NE\n\n"
"に和\n\n"
"ーーご\n\n"
"人\n"
"時\n\n"
"Androld有\n"
"和2 :501914】 9\n\n"
"川串串川\n"
"ALL FOR EVERYONE |EVERY|\n\n"
"ONE\n\n"
" \n"
" \n\n"
" \n"
" \n\n"
" \n\n"
" \n\n"
" \n\n"
"ギフト券5万円分や\n"
"ドライブ準備ダッズが\n"
"にたと ワクシンる\n\n"
" \n\n"
"<021年5月31日(月) まで\n\n"
"<021年 5月16日\n"
"伝No: 10202\n\n"
"「お得」に給油できるカード\n"
"アポロステーションカード会員胡集中 !\n\n"
"ーーーーーーーーーーーー\n"
"ーーーーーーーーーーーーーーーーー\n\n"
"2021年 5月16日\n"
"11:04\n\n"
"欄\n"
"光外ゲット 07-352859XXXXXX0007\n\n"
"P- 1(内)\n"
"Bl43.0 4293円\n\n"
"ーーー…ーーーー ms\n\n"
"ーーーーーーーーーーーーーー-\n\n"
"号 : 0817501329264\n\n"
"生処理通番 : 03119\n"
"の本Sndai\n"
"(株) 万代 堺天庭寺店\n"
"Tel:072-294-5020\n\n"
"PND / WWWy WWYWY TWOt Cx ey\n\n"
"本\n\n"
"毎通土曜日にWandaipayで支払うと\n"
"ポイントが9信じなりますイイ\n"
"ぜひご利用くだ\n\n"
"Z021年 5月21日 (金) 12:08\n\n"
"州12 本仕込食パン6枚切 \\100\n"
"較ダントツン対象品\n"
"腹18 アサリ \\371\n"
"01 P マヨネーズ45 呆68\n"
"\\98\n"
"\\78\n"
"真鯛お造り (装殖) Ya99\n"
">造\n"
"内18 4しめさばお痢り \\399\n"
"帰18 A鐘シーフードミック \\399\n"
"準18 A妃 えびいかミック \\399\n"
"敗18 Aきはだまぐろお造り \\399\n"
"用18 A冷凍むきえび \\399\n"
"*% 3個 \\1. 000 -\\394\n"
"\\2. 394を\\2, 000にしました\n"
"#09 B伊藤朝のフレッシュロ\n"
"\\268 2Z個 \\536\n"
"*B 2個 \\500 -\\36\n"
"\\536を\\500にしました\n"
"1 Cニッスイ生ちくわ\n"
"_\\78 2個 \\156\n"
"較ダントツン対象品\n"
"11 Cやまみもっちり絹厚揚 \\78\n"
"准11 C海からサラダST 1 2 き78\n"
"*C 4個 \\300 -\\12\n"
". *W312を\\300にしました\n"
"較グダントン対象品\n"
"州12 Dモッツァレラスライ 158\n"
"還ダントツン対象品 6\n"
"州12 DKスライスチーズ 7 158\n"
"*D 2個 \\300 -\\16\n\n"
"_ *316を\\*300にしました\n"
"層ダントツ対象品\n\n"
"小 20点 \\3, 9d3\n"
"9 8.0%ぶ \\3, 9d3)\n"
"8.0% 消 *319\n\n"
"人ar\n"
"ョ コカラファイン\n\n"
"ココロ、カラタ* ゲンキ。\n\n"
"ココカラファイン堺大許寺店\n"
"072-289-8488\n\n"
"店No:700161 レジNo:0003\n\n"
"Z021年05月25日(火) 11時34分\n"
"く外天 X 言E>\n\n"
"\\217内\n\n"
"Px5倍\n"
"ドライ&ドライコンパク ト \\162内\n"
"P4902407394026\n\n"
"00 内税対象額\n\n"
"3 内、消費税額\n"
"ラルジが 中\n\n"
"ポポポポ※※※※※※※1476\n\n"
"ll\n"
"果計ポイント /9上\n\n"
" 2023年03月 迄有効\n\n"
"記正に領収いたしました\n\n"
"0\n\n"
"布等に入 百、\n"
"電 と折り返し保管\n"
"3うCOINS\n\n"
"NAMBAな んなん店 No.788(4788)\n\n"
"虫寺kk の5一BB31-ー18388g\n\n"
"2021年 3月29日(月) 13:19 No:0002\n\n"
"2255713336457\n"
"MDNIIMOt27トュッツク 7りーブー \\300\n"
"Z255714133628\n"
"0 76B57イヤルスステルオイヤルポッ \\1. 500\n"
"2234715202437\n\n"
"ー\n\n"
"0784明水速連1分丈!\"ッ \\300\n\n"
"IN Bl *2.100 議識\n"
"外税対象額 10.00% \\2.100 重\n\n"
"外税 10.00%\\210\n"
"富守言十 2 SMO\n\n"
"お預り や231 G\n"
"(消費税等 \\210)\n"
"/EON FOOD STYLE\n\n"
" \n\n"
"イオンフードスタイル杏・美木多店\n"
"TEL072 - 297 - 1800\n\n"
"必若社ダイエ\n\n"
"ダイエー アプリ会員募集中\n"
"毎日お得なクーポンが配信されます\n"
"『ダイエー公式アプリ』で検索 !\n"
"店長 松井 信宏\n\n"
"!ゲ0187 2021/ 3/11(木) 15:12\n"
"取5777 責:180877187\n\n"
"山型食パン6枚 88※\n"
"TVりんごどYG 118※\n"
"ハイジの白いクルミロー 100※\n"
"ey 8※※\n\n"
"小計 \\404\n"
"外税 8%対象額 \\404\n"
"外税 8% \\32\n\n"
"合 計 \\43選\n"
"クレジット \\436\n"
"お釣り 学〇\n\n"
"お買上商品数:4\n"
"※印は軽減税率8 %対象商品\n\n"
"[クレジットカード売上票]\n"
"(お客様控え)\n\n"
"本人確認省略\n\n"
"カード会社 UFJヵカト\" 49860\n"
"計員番号 XXXX-XXXX-XXXX-1016\n"
"お取扱日 2021年03月11日\n"
"取引内容 お買上 (IC)\n"
"伝票番号 187729\n"
"取扱区分 1 回\n"
"金 額 \\436\n\n"
"承認番号 O4561985\n"
"AID A0000000031010\n\n"
"ISACREDIT\n"
"FamilyMart\n\n"
"0 交美木多駅前店\n"
"人 匠 府 堺市南区原山台2 本 1 〆\n"
"恵話 072-284-2315\n\n"
"杏 収 証\n\n"
"2021年 3月29日 (月) 09:55\n\n"
"UN 、 フリント代Q\n"
"上記正に領収いたしました\n"
"ぐ本証取扱い上のお願い\n"
"財布・手帳等に入れ保管\n"
"印刷面を内側に折って保\n"
"もたし まう\n\n"
"管理番号 : 35162973 00114019\n\n"
"2\n"
"頂\n"
"官\n"
"Seria ^\n\n"
"表 MX 書\n\n"
"トナリエ種・美木多店 2215\n"
"TEL072-247-5212 ルツ2 73680\n"
"2021/03/29(月) 14:09\n\n"
"100\n"
"100\n"
"200\n\n"
"20\n\n"
"\\220\n\n"
"(10%対象 220)\n"
"お預り \\220\n\n"
"商品不良は返品・交換承ります。\n"
"お客様ご都合の場合レシートと商品\n"
"(開封済とお客様注文除く) を下記\n"
"期間内にお持ちください。\n\n"
"く返品・交換期間>\n\n"
"雑貨 2021/03/29<2021/04/29\n"
"食品 2021/03/29(※)\n\n"
"※店外に出られていない場合に限る\n\n"
"川川川川川川\n"
"【@】 ァィリー カナート\n\n"
"イズミヤ原山台店 TEL 072-296-3388\n"
"領 収 証\n\n"
"いらっつしやゃやいませ\n"
"電子マネ-|itta払いがお得! |\n"
"ポ秘トが2僅となり大変お得! !\n"
"初めてチャージされただたお客様には\n"
"なんと ! 200円の-がドカ有 1! !\n"
"2021年05月29日(土)11:47 \"0703\n"
"責No00030111六丸\n"
"002459りけりットリー テッ2イ 7-ス2 \\398\n"
"002621 1カウイーソリルッ\" 6 ャYY \\98\n"
"002222をかつおたたき成り ( \\298\n"
"002222多いさぎ造り \\398\n"
"002585錠トク2 サ99ドッツ TM \\178\n"
"002194多>りエ叩ツ>2 N \\358\n"
"002422多\"モト 秘が>8GX40P \\498\n"
"002751 ト#り アワリ好\"りり2M60 \\150\n"
"AOO02823$筆すけッ9ウ7ゲがルチキッ\n"
"2コX単298 \\ロ96\n"
"*※※※※※※※※ まとめの値引き *******\n"
"A中華よりどり( 2個) -16\n"
"\\596から \\580に致します\n"
"小計 \\2. 956\n"
"(外8% 対象 \\2. 806)\n"
"外8% \\224\n"
"(外10% 対象 \\150)\n"
"外10% \\]15\n"
"外税計 W239\n"
"含計/ 10上店 3。 1コロ\n"
"ク し ジット MM 195\n"
"机市南区大麻寺872-5\n"
"TEL 072-297-0952\n\n"
"c0Z1年 5月28日 (金) 10:58 #O00001\n"
"009010満敵 009010漠滑\n"
"0133\n\n"
"外10 白鶴 まる 3 特 *2.300\n"
"( 2個 x @1.150)\n\n"
"外8 推独還のめんそうめん 特 \\178\n\n"
"外8 ア妹ッッ?以\"-26個 特 w148\n\n"
"欠8 多\"うチコパがガ 6個 待 914\n\n"
"(外科5%対銀客\n"
"外刀額\n"
"(外科10%半業額\n"
"万代 堺大庭寺店\n"
"Tel:072-294-5020\n\n"
"to7/ Www mandai netLGO」D\n\n"
"語まKKホ%ホwwホホネポポネポポポ\n\n"
"9 目にmandaipayで支払うと\n"
"いい ご 本\n"
"ポポ氷水水氷氷氷氷ポポポポポ\n\n"
"2021年 5月28日 (金) 11:19\n\n"
"| \\98\n"
"\\98\n"
"\\188\n"
"\\]100\n\n"
"\\399\n"
"\\153\n\n"
"沈 8 0 2 200\n"
"8.0/ 消費税等 Y176\n\n"
"。 y176\n"
"利率商品です。\n\n"
"番号 *ktttK44Kht45440\n"
"= ココカラファイン\n\n"
"ココロ、カラダ ゲンキ。\n\n"
"ココカラファイン堺大庭寺店\n\n"
"072-289-8488\n\n"
"店No:700161 レジNo:DOO3\n\n"
"2021年05月25日(火) 11時34分\n"
"ぐ欠買 HI叉 言上上ク\n\n"
"キズemの \\217内\n"
"P4960085213411\n"
"Px5倍\n\n"
"ドライ&ドライコンパクト 判62内\n"
"P4902407394026\n\n"
"(10%内税対象額\n"
"(10%内税額\n\n"
"ーー\n"
"っ Nd\n"
"(内、消費税額\n"
"】ツライ の リト\n\n"
"衝 PD\n\n"
"還ポイント 15P\n\n"
"泉計ポ イント 73P\n"
"2023年03月返有効\n\n"
"上記正に領収いたしました\n"
"、 保管上のお願い>\n"
"財布等に入れ保管頂く場合、\n"
"印刷面を内側に折り返し保管\n"
"び Iandoi\n\n"
"(株)万代 堺大庭寺店\n"
"Tel:072-294-5020\n\n"
"http 7のvww mandai met Gojp\n\n"
"1 本\n\n"
"こmand\n"
"ポイ: ントが3展になり うと\n"
"ぜひご利用くださいませ\n"
"求素素求求素求氷素求来求素求素素\n\n"
"2021年 5月25日 (火) 11:57\n\n"
"州08 内 枚 \\532\n"
"MM 1 \\168\n"
"州01 0 \\598\n"
"#12 醒 (6) \\100\n"
"首18 M は厚 口お造り \\285\n"
"州18 カツオタタキお千 造り \\388\n"
"ソ05 玉疾\n\n"
"剖8 2個 \\96\n"
"#05 ぶなしめじ \\98\n"
"州11 日水鏡入りちくわ3本\n\n"
"二の IM 5 旨 \\200\n"
"ドジめ ロロ\n\n"
"#04 バナナ \\98\n"
"#05 レタス\n\n"
"\\88 2個 \\176\n"
"州00 プロッコリー \\/8\n"
"J#05 和人参\" \\98\n"
"州05 A4きゅうり\n\n"
"\\38 3個 \\]14\n"
"*A 3個 \\98 -\\16\n\n"
"\\114を\\98にしました\n\n"
"9 8 吉富 旨009\n\n"
"0% 消費税等 \\241\n\n"
"放 \\241\n"
"#| は軽減税率対象商品です。\n\n"
"合計 \\。 ジロ4\n"
"介イント利用 回 %4\n"
"現計 学づ,。ジ50\n"
"lo \\4, OOO\n"
"お釣り 学ア5らO\n\n"
"会貞番号 *K*********#5440\n\n"
"ぐくくポイント1 UE\n"
" ポイント対象金額\n\n"
"ポイント 90 P\n"
"0 0 0\n"
"イント 0\n"
"の 2の7/ んででん\n"
"Cmいddcai\n\n"
"(株) 万代 坦大庭 者 店\n"
"「el: 072- '294 9020\n\n"
"LtD\n\n"
"心丘 6\n"
"中 。 収 書\n"
"求素素水素素来素来※ ※ 玉素来系\n"
"毎週] 曜[ N mandaipay?\n"
"ポイントが なります\n"
"ばの \"利用く ださいま+\n"
"NN\n\n"
"2021年 5月26日 (水) 11:43\n\n"
"12 Kもちふわ (6) \\98\n"
"州01 Kマン 本つゆ1L 状98\n"
"一ダントン対象品\n"
"州05 セロリ \\138\n"
"州05 青ねぎ \\98\n"
"州20 おいしい牛肉コロッケ\n"
"\\200 2個\\400\n"
"fh ニッスズスイ ちくわ\n"
"、W78 2個 \\156\n"
"一ゲントツ和象品\n"
"州01 ハウス 特選生わさ \\118\n"
"田ダントン対象品\n"
"VH05。しよう97還 \\98\n"
"誕18 しめさばお造り \\399\n\n"
"小計 11点\\1,703\n"
"(外科 8.02計多額 。 *703\n"
"小生計 MS\n"
"| は軽減税率対旬商品です。\n\n"
"合計 1 。 3はS!\n"
"ポイント利用 1回 Y\\39\n\n"
"現計 半1. 8りDO\n"
"お預り 学1D。 OOO\n\n"
"お釣り さこ 919」\n\n"
"会員番号 *********5440\n\n"
"ンンポイント情報シン\n"
"ポイント対象金額 ” 1709 円\n\n"
"SL メ\n"
"れ か 4だる\n\n"
"iUU 00059 人 3 持\n"
"0203549 小山\n"
"j]\n\n"
"首川 N 則\n\n"
"0039591 50\n"
"に の邊\n\n"
"CCCED\n\n"
" 堺大許寺 2 号店\n"
"072-288ー8001\n\n"
"還 領収 書 画\n\n"
"生度ありがとうございます。\n\n"
"て返品の史はレシートとTカード\n"
"をご持参の上 1 週間以内にご来店\n"
"ください。\n\n"
"店No:6625 レジNo:0004\n"
"2021年05月26日(水) 11時21分\n\n"
"34 7ぴのBME1衝-加びリ \\198\n"
"4902111764092\n"
"38 7997SC加 \\316\n"
"4901301335180\n"
"@158 X2個\n"
"38 人Xゲ99りDSP加 \\| 76\n"
"4901301310231\n"
"@88 X 2個\n"
"32 45\"rII2v4\" 107 \\1 780\n"
"4891228303938\n"
"アイテム割引10%\n\n"
"消費税等(外税) 10% \\229\n"
"(外税対象額 \\2, 292)\n"
"で生言十 \\2, 521\n\n"
"\"(内、消費税等 M229)\n\n"
"ポイント利用 \\21\n"
"ポイント利用後残金 \\2, 500\n\n"
"現金預り \\2, 500\n"
"にと| \\0\n"
"画較較圏 「ボイント情報 画画画\n"
"1会員番号 ・ 1573\n\n"
"前回\"イト と 56P\n"
"今回利用ポト : ョZIR\n"
"利用可能* イト : 35P\n\n"
"今回 似ト合計 : 22P\n"
"(通常ポト : 22P)\n"
"男圏画遼較較遼囲囲間遼較較圏時較\n"
"画賠圏圏 |マネー情報 回回男画\n"
"Tマネー残高 : y_\n"
"較較半間間間間題章間半量是暗量間\n"
"本日獲得された# 侯トは2-3日目\n"
"以降に反映されます。]かド が無効\n"
"の場合、T* 似トは貯まりません。\n"
"(詳細はtsite.jpにてご確認下さい)\n"
"信和7トド の紛失・ 磁気不委、ド 1修の\n"
"履歴確認は、Tかド 9 -ト29-\n"
"0570-029-294(9時30分て18時)\n"
"のが01422000130301AANNNNNNN\n"
"@店舗や9-上人に関するお問合せは\n"
"27お客様9-上\"人77- [\n"
"120-119-358 (受付:9時>20時)\n\n"
"川串\n\n"
"担当者!邊葉")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.