$re = '/\b(?<![\x80-\xFF])[a-zA-Z\']+(?![\x80-\xFF])\b/';
$str = 'JÖNAS
Hélton
As kingfishers catch fire, dragonflies draw flame;
As tumbled over rim in roundy wells
Stones ring; like each tucked string tells, each hung bell\'s
Bow swung finds tongue to fléing out broad its name;
Each mortal thing does one thing...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);