# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?<![\x80-\xFF])[a-zA-Z']+(?![\x80-\xFF])\b"
test_str = ("JÖNAS\n"
"Hélton\n"
"As kingfishers catch fire, dragonflies draw flame;\n"
"As tumbled over rim in roundy wells\n"
"Stones ring; like each tucked string tells, each hung bell's\n"
"Bow swung finds tongue to fléing out broad its name;\n"
"Each mortal thing does one thing...")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.