#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*?Location1.*?q=(.*?),(.*?)".*?(\r|$)|.*?(\r|$)"
Local $sString = "Text A Location1 More text q=1,2)" Even more text" & @CRLF & _
"Text B" & @CRLF & _
"Text C Location1 More text q=3,4)" Even more text" & @CRLF & _
"Text D"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")