$re = '/.*?Location1.*?q=(.*?),(.*?)".*?(\r|$)|.*?(\r|$)/m';
$str = 'Text A Location1 More text q=1,2)" Even more text
Text B
Text C Location1 More text q=3,4)" Even more text
Text D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);