// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z]{2}\d{27})$").unwrap();
let string = "0444845519
0444845519a
0444845519FFF
3235519
2654444444
123456789
12345678
111111111111111111111111111111
UA903052992990004149123456789
UA9030529929900041491234567895
UA90305299299000414912345678
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}