using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?<=\\0_ASW\\)|(?<=\\10_BSW\\))[A-Za-z0-9]+";
string input = @"C:\MyPath\0_ASW\Mod2000
C:\MyPath\0_ASW\Mod2005\SubDir
C:\MyPath\10_BSW\ModA\SubDir
C:\MyPath\10_BSW\ModB
C:\MyPath\10_BSW\ModC\
C:\MyPath\10_ASW\ModC\
C:\MyPath\nothing\ModC\
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}