re = /\b(?:(?<=\\0_ASW\\)|(?<=\\10_BSW\\))[A-Za-z0-9]+/m
str = 'C:\\MyPath\\0_ASW\\Mod2000
C:\\MyPath\\0_ASW\\Mod2005\\SubDir
C:\\MyPath\\10_BSW\\ModA\\SubDir
C:\\MyPath\\10_BSW\\ModB
C:\\MyPath\\10_BSW\\ModC\\
C:\\MyPath\\10_ASW\\ModC\\
C:\\MyPath\\nothing\\ModC\\
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end