package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d`)
var str = `1е место: Винни
2е место: Пятачок
3е место: Слонопотам`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}