$re = '/^\d/m';
$str = '1е место: Винни
2е место: Пятачок
3е место: Слонопотам';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);