package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w\x{0021}-\x{003F}]+`)
var str = `एकa1!a?23!sd2अ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}