$re = '/[\w\x{0021}-\x{003F}]+/';
$str = 'एकa1!a?23!sd2अ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);