using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((<LastName>)(.*)(<LastName>))\b(?![\s\S]*\b\1\b)";
string input = @" <LastName>Adams</LastName>
<LastName>Adams</LastName>
<LastName>Yellow</LastName>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}