re = /\b((<LastName>)(.*)(<LastName>))\b(?![\s\S]*\b\1\b)/m
str = ' <LastName>Adams</LastName>
<LastName>Adams</LastName>
<LastName>Yellow</LastName>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end