import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ab]([ab])(?![ab]*\\1$)[ab]*$";
final String string = "aaabbbbababab\n\n"
+ "aaabbbbababaa\n"
+ "ababbbbababab\n"
+ "ababbbbababaa\n"
+ "abb\n"
+ "aba\n"
+ "aab\n"
+ "aaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}