re = /^[ab]([ab])(?![ab]*\1$)[ab]*$/m
str = 'aaabbbbababab
aaabbbbababaa
ababbbbababab
ababbbbababaa
abb
aba
aab
aaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end