const regex = /^[a-zA-Zа-яА-Я0-9]*(-)?(?:[a-zA-Zа-яА-Я0-9])*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Zа-яА-Я0-9]*(-)?(?:[a-zA-Zа-яА-Я0-9])*$', 'gm')
const str = `abc_def
abc-def
abc--def
abc_-def
abc-def-ghi\$jkl-mno
abc-def-ghi-jkl-mno
-abcdef-
abc
фыва-ффффw
И-Иван`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}