import Foundation
let pattern = #"^[a-zA-Zа-яА-Я0-9]*(-)?(?:[a-zA-Zа-яА-Я0-9])*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc_def
abc-def
abc--def
abc_-def
abc-def-ghi$jkl-mno
abc-def-ghi-jkl-mno
-abcdef-
abc
фыва-ффффw
И-Иван
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)