const regex = /^.*?,(?=[A-Z]{2}=)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?,(?=[A-Z]{2}=)', 'gmi')
const str = `CN=Doe\\, Jane,OU=Users,DC=domain,DC=com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}