$re = '/^.*?,(?=[A-Z]{2}=)/mi';
$str = 'CN=Doe\\, Jane,OU=Users,DC=domain,DC=com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);