package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[0-9]+\b`)
var str = `a bcd 43.43 432 и л фвыа 89 .98`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}