$re = '/\b[0-9]+\b/m';
$str = 'a bcd 43.43 432 и л фвыа 89 .98';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);