using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\w)(?:0|[1-9]\d+)?\.\d+\b";
string input = @"a bcd 43.43 432 и л фвыа 89 .98
fdfdfd.98dsfs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}