re = /(?<!\w)(?:0|[1-9]\d+)?\.\d+\b/m
str = 'a bcd 43.43 432 и л фвыа 89 .98
fdfdfd.98dsfs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end