$re = '/(?<![.a-zA-Z_0-9])\d+(?![a-zA-Z_0-9])/m';
$str = 'a bcd 43.43 432 и л фвыа 89 .98
fdfdfd.98dsfs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);