import re
regex = re.compile(r"^(?=.*?[A-Z])[^0-9].{7,}$", flags=re.MULTILINE)
test_str = ("fdhf\n"
"fdifhidhfdfd\n"
"hfhfhfhf\n"
"3343rAjrj\n"
"bd1A23nfdd\n"
"bd123nfDdd\n\n"
"abd16A3n\n"
"bad176A23n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")