$re = '/(\d+).*\1/m';
$str = '123;456;789
123;123;456
123;123;123
123;456;456
123;456;123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);