re = /(\d+).*\1/m
str = '123;456;789
123;123;456
123;123;123
123;456;456
123;456;123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end