// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(?(DEFINE)
(?<void>br|img|area|base|col|command|embed|hr|input|keygen|link|meta|param|source|track|wbr|!DOCTYPE)
(?<any>[^<>]*+)
)
<div \s class="card">
(?P<pair> (?&any)
(:?
<(?P<v_tag>(?!\/)(?&void))(?&any)> (?:(?&pair) | (?&any))*+ (<\/(?P=v_tag)>)? |
<(?P<tag>(?!\/)[^<> ]++)(?&any)> (?:(?&pair) | (?&any))*+ <\/(?P=tag)>
) (?&any)
)*
<\/div>"#).unwrap();
let string = "<!DOCTYPE html>
<html>
<head>
<title>Example</title>
</head>
<body>
<div class=\"card-container\">
<div class=\"card\">
<h5>First MD Card</h5>
<img src=\"https://mdbootstrap.com/img/Photos/Horizontal/Nature/4-col/img%20(34).jpg\" alt=\"Card image cap\">
<p>
Lorem ipsum dolor sit amet consectetur adipisicing elit. Sapiente
fugiat accusamus excepturi rem temporibus nobis natus.
</p>
</div>
<div class=\"slider\">
<ul class=\"progress-bar\">
<li class=\"active\"></li>
<li></li>
<li></li>
</ul>
</div>
</div>
</body>
</html>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}