import Foundation
let pattern = #"""
(?(DEFINE)
(?<void>br|img|area|base|col|command|embed|hr|input|keygen|link|meta|param|source|track|wbr|!DOCTYPE)
(?<any>[^<>]*+)
)
<div \s class="card">
(?P<pair> (?&any)
(:?
<(?P<v_tag>(?!\/)(?&void))(?&any)> (?:(?&pair) | (?&any))*+ (<\/(?P=v_tag)>)? |
<(?P<tag>(?!\/)[^<> ]++)(?&any)> (?:(?&pair) | (?&any))*+ <\/(?P=tag)>
) (?&any)
)*
<\/div>
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
<!DOCTYPE html>
<html>
<head>
<title>Example</title>
</head>
<body>
<div class="card-container">
<div class="card">
<h5>First MD Card</h5>
<img src="https://mdbootstrap.com/img/Photos/Horizontal/Nature/4-col/img%20(34).jpg" alt="Card image cap">
<p>
Lorem ipsum dolor sit amet consectetur adipisicing elit. Sapiente
fugiat accusamus excepturi rem temporibus nobis natus.
</p>
</div>
<div class="slider">
<ul class="progress-bar">
<li class="active"></li>
<li></li>
<li></li>
</ul>
</div>
</div>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)