import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.......$";
final String string = "test.txt\n"
+ "passwords.json\n"
+ "notes.doc\n"
+ "test2.txt\n"
+ "dont't forget!!!.txt\n"
+ "app.cfg\n"
+ "send.rtf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}