import re
regex = re.compile(r"^.......$", flags=re.MULTILINE)
test_str = ("test.txt\n"
"passwords.json\n"
"notes.doc\n"
"test2.txt\n"
"dont't forget!!!.txt\n"
"app.cfg\n"
"send.rtf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")