import Foundation
let pattern = #"\[<a(\s+[a-zA-Z\-][a-zA-Z0-9\-]*(=("[^"]*"|'[^']*'|[a-zA-Z0-9\-_]+)?)?)*\s*>([^<]|<[^a]|<a[^ >])+<\/a>\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<div>
<br/>
<div style="text-align: left;">
<p style="margin-top: 0px; margin-bottom: 0px;"> [<a id="Offer no. SGE - 100818 - 2 - Klb (24XLR - steel washing).doc" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/Offer%20no.%20SGE%20-%20%20100818%20-%20%202%20-%20Klb%20(24XLR%20-%20steel%20washing).doc">Offer no. SGE -  100818 -  2 - Klb (24XLR - steel washing).doc</a>] [<a id="_PO4501258976_EUR.pdf" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/_PO4501258976_EUR.pdf">_PO4501258976_EUR.pdf</a>] </p>
</div>
<br/>
<div style="text-align: left; color: #000000; font-family: arial, san-serif; font-size: 9pt;">
<p style="margin-top: 0px; margin-bottom: 0px;">Rechnungen im Einzelnen (lt. Linda Gölzenleuchter/Praktikantin RTB) Stand 05.05.2011</p>
</div>
<br/>
<div style="text-align: left;">
<p style="margin-top: 0px; margin-bottom: 0px;"> [<a id="2011_05.pdf" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_05.pdf">2011_05.pdf</a>] [<a id="2011_01.pdf" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_01.pdf">2011_01.pdf</a>] </p>
</div>
</div>
<br/>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)