const regex = /(?<=-M[5-7]-)\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=-M[5-7]-)\\d+', 'gm')
const str = `0124-M5-2260-1400
1225-M6-1015-1400
3023-M7-1005-1400`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}