re = /(?<=-M[5-7]-)\d+/m
str = '0124-M5-2260-1400
1225-M6-1015-1400
3023-M7-1005-1400'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end