import re
regex = re.compile(r"[-?|\D?]\d{2}\D?\d{2}\D?\d{4}\s??[-|–]?\s?\d{2}\D?\d{2}\D?\d{4}")
test_str = ("Chiết khấu tháng: '0.04-01/01/2020-31/12/2020 .Chi trả kết thúc hàng tháng\n"
"Từ 01/01/2020-31/12/2020 TSL >=1500 tấn thưởng: 1% doanh thu, TSL >=1800 tấn thưởng: 1.5% doanh thu (chi trả kết thúc chương trình, dự chi mức 1.5% doanh thu)\n"
"Chiết khấu quý :01.01.2020-30.06.2020 :trừ 9048\n"
"1 HĐ CK01 1% 9048 từ 01/02/2020 - 31/05/2020\n"
"Chiết khấu TSL 3 tháng = 100 tấn 01/01/2020 31/03/2020;200 đ/kg Chi trả khi hoàn thành sản lượng, Sau điều chỉnh Từ 01/01/2020 -31/03/2020 chiết khấu TSL 3 tháng = 90.895kg: 200đ/kg (chi trả kết thúc chương trình)\n"
"Chiết khấu Năm 29/02/2020 đến 31/01/2021 1% Trong vòng 45 ngày kể từ thời điểm đủ 12 tháng kinh doanh liên tục.\n"
"Chiết khấu Tháng - Trừ SP 8888, 6688, 5588S, 8954, cá các loại 01/02/2020 – 31/01/2021 4% Ngày 10 tháng kế tiếp")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")