package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((.*?)(\(\w{1,}\)))((\g<2>)(\g<3>))*`)
var str = `Geese (Flock) Dogs (Pack)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}