package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\w]{1,}[\w.+-]{0,}@[\w-]{2,}([.][a-zA-Z]{2,}|[.][\w-]{2,}[.][a-zA-Z]{2,})$`)
var str = `first-name.last-name@domain-name.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}