re = /^[\w]{1,}[\w.+-]{0,}@[\w-]{2,}([.][a-zA-Z]{2,}|[.][\w-]{2,}[.][a-zA-Z]{2,})$/
str = 'first-name.last-name@domain-name.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end