package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/src\/main\/java(\/[^\/]+)?\/\*\.java$`)
var str = `/src/main/java/{any_package}/*.java
/src/main/java/*.java`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}