$re = '/^\/src\/main\/java(\/[^\/]+)?\/\*\.java$/m';
$str = '/src/main/java/{any_package}/*.java
/src/main/java/*.java';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);