#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?(?:(?:Name: (.+?)|(Address: )(.+?)|City: ((?(2).*?Address: )*.+?))\t*)+$"
Local $sString = "Name: John Doe Address: Street 123 ABC " & @CRLF & _
"Name: John Doe Address: Street 123 ABC City: MyCity" & @CRLF & _
"Some other textName: John Doe Address: Street 123 ABC City: MyCity" & @CRLF & _
"Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address" & @CRLF & _
"City: MyCity Address: Street 123 ABC Name: John Doe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")