package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?:(?:Name: (.+?)|(Address: )(.+?)|City: ((?(2).*?Address: )*.+?))\t*)+$`)
var str = `Name: John Doe Address: Street 123 ABC
Name: John Doe Address: Street 123 ABC City: MyCity
Some other textName: John Doe Address: Street 123 ABC City: MyCity
Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address
City: MyCity Address: Street 123 ABC Name: John Doe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}