#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) \d+[,\.]?(\d)* ?[\w\/]+ ?(\([\d \.,\w%]+\))?"
Local $sString = "NITROPRUSSETO DE SODIO 50MG (25 MG/ML)" & @CRLF & _
"ALFAINTERFERONA 2A 3.000.000 UI" & @CRLF & _
"CLORETO DE SODIO 9MG/ML (0,9%)" & @CRLF & _
"BICARBONATO DE SODIO 84MG/ML (8,4%)" & @CRLF & _
"VITAMINA B6 100MG (PIRIDOXINA), VITAMINA B1 50.2MG (TIAMINA), VITAMINA B12 100,5 MCG (CIANOCOBALAMINA), DIPIRONA SODICA 250 MG, CARISOPRODOL 250 MG" & @CRLF & _
"PAPAVERINA 10MG/ML, DIPIRONA MONOIDRATADA 333 MG/ML, ATROPA BELLADONNA LINNA(C) - EXTRATO 6MG/ML (EQUIVALENTE A 0,075MG/ML DE HIOSCIAMINA), HYOSCYAMUS NIGER LINNA(C) - EXTRATO 6MG/ML (EQUIVALENTE A 0,0135MG/ML DE BROMIDRATO DE ESCOPOLAMINA), PEUMUS BOLDUS MOLINA - EXTRATO 12MG/ML (EQUIVALENTE A 0,0142MG/ML DE BOLDINA)" & @CRLF & _
"DIPIRONA MONOIDRATADA 300 MG/ML, ESCOPOLAMINA, BUTILBROMETO 6,5 MCG/ML, HIOSCIAMINA, BROMETO 0,104MG/ML, HOMATROPINA, METILBROMETO 1MG/ML" & @CRLF & _
"ACIDO ASCORBICO 1 G (10%), ARGININA, ASPARTATO 1G(1.000 MG)" & @CRLF & _
"GLICOSE 50 MG/ML (5%)" & @CRLF & _
"" & @CRLF & _
" \d+[,\.]?(\d)* ?[\w\/]+ ?(\([\d \.,\w%]+\))?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")