$re = '/ \d+[,\.]?(\d)* ?[\w\/]+ ?(\([\d \.,\w%]+\))?/m';
$str = 'NITROPRUSSETO DE SODIO 50MG (25 MG/ML)
ALFAINTERFERONA 2A 3.000.000 UI
CLORETO DE SODIO 9MG/ML (0,9%)
BICARBONATO DE SODIO 84MG/ML (8,4%)
VITAMINA B6 100MG (PIRIDOXINA), VITAMINA B1 50.2MG (TIAMINA), VITAMINA B12 100,5 MCG (CIANOCOBALAMINA), DIPIRONA SODICA 250 MG, CARISOPRODOL 250 MG
PAPAVERINA 10MG/ML, DIPIRONA MONOIDRATADA 333 MG/ML, ATROPA BELLADONNA LINNA(C) - EXTRATO 6MG/ML (EQUIVALENTE A 0,075MG/ML DE HIOSCIAMINA), HYOSCYAMUS NIGER LINNA(C) - EXTRATO 6MG/ML (EQUIVALENTE A 0,0135MG/ML DE BROMIDRATO DE ESCOPOLAMINA), PEUMUS BOLDUS MOLINA - EXTRATO 12MG/ML (EQUIVALENTE A 0,0142MG/ML DE BOLDINA)
DIPIRONA MONOIDRATADA 300 MG/ML, ESCOPOLAMINA, BUTILBROMETO 6,5 MCG/ML, HIOSCIAMINA, BROMETO 0,104MG/ML, HOMATROPINA, METILBROMETO 1MG/ML
ACIDO ASCORBICO 1 G (10%), ARGININA, ASPARTATO 1G(1.000 MG)
GLICOSE 50 MG/ML (5%)
\\d+[,\\.]?(\\d)* ?[\\w\\/]+ ?(\\([\\d \\.,\\w%]+\\))?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);