$re = '/^(\d{4})/m';
$str = '1874[71]-88
1848, 50
[1820?]
1883
1864-72
1885, [1884]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);