import re
regex = re.compile(r"^(\d{4})", flags=re.MULTILINE)
test_str = ("1874[71]-88\n"
"1848, 50\n"
"[1820?]\n"
"1883\n"
"1864-72\n"
"1885, [1884]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")