const regex = /(yes)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(yes)', 'g')
const str = `on ok ok ok on
no ok no zip
zip ok no ok zop
zip ok zop no ok zap
zip no ok no`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}